ごちゃごちゃメモ@UO

米国公式サイトの情報はカテゴリの「[UO]パブリッシュ情報、[UO]ニュース」をクリックすると記事タイトルが一覧表示されます。クエスト情報はクエスト関連の「クエスト一覧」をクリック! TCに新Pubが導入された場合、検証結果掲載(ネタバレ注意!) 情報が見つからないときは「サイト内検索」で探してみてください。Link Free

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
[ --/--/-- --:-- ] スポンサー広告 | TB(-) | CM(-)

UOCのための.NET Framework 2.0インストールについて

以前、紹介したUOCartograper(UOC)はマイクロソフトの「.NET 2.0 framework」SP1以上がインストールされていないと動作しない。

仲間が「.NET 2.0 framework」のインストールでつまずいて教えてあげたが、同じようにインストールできなくてUOCの利用を断念した人もいると思うからブログに書いてくれ!と言うのでインストール手順を紹介しておく。

マイクロソフトの次のページに飛ぶ。

.NET Framework ダウンロード

.NET Framework 2.0という項目からまず「Microsoft .NET Framework Version 2.0 再頒布可能パッケージ」をクリック。
選択肢が3つあると思うが使っているOSが32ビット版なら「x86 版をダウンロード」をクリックしてそれをインストール。

終わったら、上の「.NET Framework ダウンロード」ページに戻る。

次に「Microsoft .NET Framework 2.0 Service Pack 2」をクリック。
ページの下のほうに「ダウンロード」ボタンでの選択肢がやはり3つあると思うが上でx86版を選んだ場合は同じx86版を選ぶので「NetFx20SP2_x86.exe」の右のボタンを選択。

それをダウンロードインストールしたら完了だが、これらの作業の過程でPCの再起動もかかると思うので注意。

以上でUOCが起動可能になるはずだ。
なお、UOAMもそうだがUOCも初回の起動は自動的な初期設定があるので多少時間がかかるが待っていればいい。

「.NET Framework」はランタイムライブラリでアプリケーションのための関数などが定義されたものだと思えばいい。UOCの場合は「.NET 2.0 framework SP1」で定義されている関数などを使用しているため「.NET 2.0 framework」のSP1以上がインストールされていないと動作しない。

簡単な例でいうと「神奈川県の県庁所在地は横浜市である」と書かれた本があるとする。
神奈川県の県庁所在地を知らないとしてその本を読んでいないと「神奈川県の県庁所在地は?」と質問されても答えられない。

この例でいう「本」が「ランタイムライブラリ」で「質問」が「UOCの起動」だと思えばいい。つまり、「答え」を知らないと「質問に答えられない」ように、「ランタイムライブラリ」が入っていないと「UOCは起動しない」わけだ。


関連記事
[ 2010/08/10 01:08 ] [UO]トレハン | TB(0) | CM(11)
こんにちは。初めまして。いつも大変便利に利用させて頂いてます。

さて、今回もとても便利なツールがあるということで私もインストールしてみたのですが、画面が真っ暗で何も出来ない状態です。クライアントフォルダも正しいと思うのですが。

この.NET frameworkは2.0がインストールしてないといけないのでしょうか?私のウインドウズ7環境だと3.5.1がインスト済みなのですが。これでは、ダメなのかな。

もしご存知でしたら教えて下さい。お願いします。
[ 2010/08/10 16:29 ] [ 編集 ]
>kiyo tanさん
おはようございます。

.NET frameworkには次のような種類があります。

.NET framework 4
.NET framework 3.5
.NET framework 3.0
.NET framework 2.0

マイクロソフトの説明では「.NET Framework 3.5 の環境では .NET Framework 3.0 および .NET Framework 2.0 を対象に開発されたアプリケーションを実行することができます。」となっているので問題なさげですが、試しに「.NET framework 2.0」もインストールしてみたらどうでしょう?

.NET framework 2.0などの最後の数字はバージョンというよりシリーズナンバーという感じで個別にアップデートもされるので、「.NET framework 2.0」をインストールしたからといってすでに入っている「.NET framework 3.5」には影響がないと思います。

私のPCには「.NET framework 2.0」、「.NET framework 3.0」、「.NET framework 3.5」が入っていますが、最終アップデート日が「.NET framework 2.0」と「.NET framework 3.0」は同じです。

2.0や3.0がバージョンであるなら、マイクロソフトアップデートでは3.0しか更新されないのではないかと思います。
つまり、アップデートで2.0自体を3.0にアップデートすると思うからですが、私のPCには2.0も残っていていまでもマイクロソフトアップデートで更新されることがあります。

なお、UOCのスレッドを見たら「簡単なトラブル対処」みたいな部分があったので翻訳してのちほど記事本文の最後くらいに追記しますね。

[ 2010/08/11 07:21 ] [ 編集 ]
以前、UOCを利用したトレハンの方法の記事を書きましたがその記事のタイトルを「UOCを使うとPub67以降のトレハンポイント発見は楽!」に変更して、その最後にUOCにおける一般的なトラブルへの対処法を追記しました。

kiyo tanさんの場合はクライアントのパス指定が間違っていないというのであれば、やはり.NET framework 2.0がインストールされていないのが原因っぽいですね。
[ 2010/08/11 08:34 ] [ 編集 ]
お手数お掛けします。

.NET framework 2.0 SP2は頑張って調べた所インストールされてました。

いつの間にか真っ暗なのも直ったのですが、UOとリンクされてない?のかただ地図が画面上にあるというだけです。

クライアントパスは以下なんですが、
C:\Program Files (x86)\Electronic Arts\Ultima Online Stygian Abyss 2D
64bit OSなので問題ないと思うのですが。よく分かりませんねー(^-^;

とりあえず頑張って色々やってみます。有難う御座いました。
[ 2010/08/11 20:01 ] [ 編集 ]
2Dクライアントのパスが違います
>C:¥Program Files (x86)¥Electronic Arts¥Ultima Online Stygian Abyss 2D

SAが出た後の2Dクライアントをインストールするとそのフォルダなのかわかりませんが、2Dクライアントのパス名が間違っていると思います。
そのフォルダにclient.exeその他ファイルがたくさんありますか?

これはSAクライアントのインストールで作成されるもので、私の場合はそのフォルダにはファイルが数個しかありません。

2Dクライアントをインストールした場合は次のパスにインストールされているんじゃないかと思います。

C:¥Program Files¥EA Games¥ウルティマ オンライン 宝珠の守人

上のレスで書いた「UOCを使うとPub67以降のトレハンポイント発見は楽!」の記事に追記した分にUOCのパス設定画面の画像もあるので、それも見てみてください(上の内容が入力されているだけの画像ですが実際に動作している設定です)。

たぶん、パス名を直すと動くと思います。
[ 2010/08/12 05:26 ] [ 編集 ]
有難う御座います。

がパスは問題ないと思います。C:¥Program Files¥EA Games¥ウルティマ オンライン 宝珠の守人 にしますとファイルが無い旨のメッセージが出ちゃいますね。

C:¥Program Files (x86)¥Electronic Arts¥Ultima Online Stygian Abyss 2D
またこちらだとmapが読み込めない旨のメッセージが出ます。

うーん、分かりませんが、このUOCを使わなくても何とかいけてるのでツールに頼らず頑張ってみようと思います。

お手数お掛けしました。また今後とも宜しくお願いします。
[ 2010/08/13 00:24 ] [ 編集 ]
>kiyo tanさん
そうですか
そうなるとあとはUOCを管理者として起動していないなら、
管理者で起動してみるくらいしかないですが、
たぶんすでに管理者権限で起動してますよね・・・
[ 2010/08/14 07:29 ] [ 編集 ]
UOC
こちらのサイトはいつも参考にさせて貰っています。

さて、私もkiyo tan さんと同じwindows7 64bit使っていて、
UOCを起動しても「画面が真っ暗で何も出来ない状態」でした。
パスも「C:\Program Files (x86)\Electronic Arts\Ultima Online Stygian Abyss 2D」
と同じ場所にあります。

どうしたものかと考え、
UOCプロパティ→互換性→互換モードでこのプログラムを実行するにチェック→windowsXP(Service pack 2)
と変更したところ、見事に動き出しました。

kiyo tan さんの環境で正常作動するかは不明ですが、
ダメ元で試してみて下さい。

地図ソフト無しだと、トレハンがかなり厳しいですね・・・。
UOCの御蔭で可也楽になりました。
[ 2010/11/15 23:43 ] [ 編集 ]
>mochaさん
こんばんはー

UOCのトラブルシューティングに関してはいくつかの記事に分散しているので、1つの記事にまとめようと思っています。しかし、私はいまだXPしか使っていないので教えていただきたいことがあります。

私が調べたWin7で使う場合の注意点は以下のとおりになっていました。

1.UOクライアントの入っているパス名を正しく指定
2.MSの.NET 2.0 framework SP1以上をインストール
3.UOCのインストールは管理者権限で実行
4.UOCの実行時は管理者権限で実行してないけない

教えていただきたいのは上の4番目に関してです。
管理者権限でない状態でXP互換モードにすると動くのか、管理者権限であってもXP互換モードにすると動くのかということなのですが、どうなのでしょうか?
また、上の4項目と実際が違う点がありましたら教えていただけると助かります!

[ 2010/11/16 01:23 ] [ 編集 ]
自分の記憶している限りで回答致します。
と言うのも、DLや削除を繰り返した結果なので、かなり記憶が曖昧なのです。

1.先日、書いたとおりです。

2.NET framework 4 client profileが入っています。
こちらを参考に2.0等を入れようとしましたが、
何故かDLに失敗するので諦めました。

3.UOCのインストールは管理者権限で実行
(だったと思います)

4.UOCの実行時は管理者権限で実行してないけない
(管理者権限で実行したと思います・・・)

参考になるか分りませんが、こんな感じです。
今のところ、正常動作しています。
[ 2010/11/18 22:50 ] [ 編集 ]
>mochaさん
レスありがとうございます!

私が知りたかったのはUOCの説明にはXP互換モードのことはでていなかったのでたぶん互換モードでのやり方じゃない気がしたので、mochaさんのやったXP互換モードでやればUOCを管理者権限で実行してもOKなのかな?ということでした。
実際に試せないのでなんともいえませんが、XP互換モードにすれば動きそうな感じですかね?
[ 2010/11/19 01:31 ] [ 編集 ]
コメントの投稿












管理者にだけ表示を許可する
トラックバック
この記事のトラックバックURL

2010.7.9 FC2移転
Welcome
Presented by Z
どうでもいい?管理人情報
北斗のムーングロウに最初のキャラが誕生。 その後、ロストランドが実装された時にデルシアに移住(トランメルができるまでデルシアが拠点となる)。 死の街やオアシスに毎日のように通ったが、PKも毎日のように襲撃してきた(おかげで逃げ足スキルは向上)。 過去何度か休止期間があり、2013年6月に復帰したものの仲間が引退または休止中でぼっち状態に・・・

ぐりぐり

管理人:ぐりぐり

カレンダー

09 | 2017/10 | 11
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 - - - -
世界時計
画面内MAPの赤い点をクリックすると、その都市の時刻が表示されます。その国が休日の場合は時計の色が薄くなります。
サイト内検索
カテゴリ
最新記事
最新コメント

openclose

QRコード
QR


上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。